Tutorial iReport

Propaganda
Tutorial de iReport para uso no SIGA
O que é isso?
O JasperReports é um gerador de relatórios de código livre. É fácil de ser integrado
a aplicações empresariais, embora não contenha um editor de relatórios visual integrado.
Portanto, para usar diretamente o JasperReports, precisaríamos manipular sua estrutura
de relatórios XML - uma atividade relativamente complexa. Uma alternativa é usar uma
ferramenta gráfica para facilitar o seu uso. Este tutorial demonstra como uma dessas
ferramentas, o iReport, pode aproveitar todo o poder do JasperReports, sem entrar nas
complexidades do formato XML nativo.
Objetivo
A idéia é utilizar o iReport para criar relatórios sobre a base de dados do SIGA, em
vez de soluções comerciais como PDFs ou relatórios do Crystal Reports. Uma vez
criados, estes relatórios poderão ser incorporados ao SIGA.
Uma boa notícia é que quem já usou o Crystal encontrará muitas semelhanças com
esta ferramenta.
Instalação
Neste CD se encontram os arquivos necessários para instalar e usar o iReport (que
já inclui o próprio JasperReports). Siga os passos abaixo:
1) O cliente Oracle precisa estar instalado na sua máquina e com o JDBC (Java DataBase
Connectivity - o que permite a conexão entre aplicativos Java e os bancos de dados).
Dependendo da versão do cliente Oracle, a pasta que nos interessa pode ser
c:\Oracle\Ora81\jdbc\lib ou c:\orant\jdbc\lib. Verifique a existência de uma destas pastas
em sua máquina (ela deve conter alguns arquivos como classes102.zip ou
classes111.zip; se o diretório não existir, reinstale o cliente Oracle). Copie o arquivo
classes12.zip do CD neste diretório.
2) Instale o Java na sua máquina (se já não o tiver). No CD encontra-se o JDK 1.6
completo (jdk-6-windows-i586.exe).
3) Instale o iReport. No CD rode iReport-1.3.1-windows-installer.exe.
Obs.: Esta instalação é para uso em Windows. Para instalação em Linux ou outras
plataformas, tanto o Java como o iReport tem versões que podem ser usadas e vale tudo
que estiver descrito neste tutorial. O único detalhe que mereceria estudo adicional é o
cliente Oracle com seu driver JDBC.
1
Configurando o iReport
Após a instalação, conforme acima, rode o iReport.
1) Entre em “Options – Classpath” e clique em “Add JAR”. Indique ao iReport o arquivo
classes12.zip, instalado no item anterior. Clique no botão “Save Classpath”.
2) Adicione uma nova conexão referente ao banco de dados. Use o menu "Data Connections/Datasources" para tal. A janela estará vazia. Clique no botão “New”. Entre
com os dados conforme figura abaixo:
O exemplo acima usa o banco de teste (a senha está mascarada, mas você sabe
qual é...). Clique no botão “Test”. Se estiver tudo certo, deve funcionar. Salve com “Save”.
3) Crie uma nova conexão para o banco “quente”, trocando o “Name” para ufjfq (por
exemplo) e altere os campos “Server Adress”, “User Name” e “Password” de acordo.
4) Na janela que surgir após a criação da conexão, marque qual banco deve ser o
“default”, com o botão “Set as Default”.
2
Criando um Relatório de Teste
Crie um novo documento JasperReports usando o item de menu "File/New
Document". Apenas daremos um nome ao relatório: “Paises”. Podemos ignorar todas as
demais opções por enquanto. Clique em “OK”. Teremos assim um relatório vazio. Um
relatório JasperReport é dividido nas seções de exibição mostradas na tela iReport:
1. Title: como o nome o indica, esta seção contém o título do relatório;
2. Page Header: esta seção aparece no topo de cada página (como esperado). É um
bom lugar para colocar datas, numeração de páginas, etc.;
3. Column Header: esta seção aparece no topo de cada coluna;
4. Detail: nesta área serão colocadas as informações para cada item de registro. O
JasperReports gera uma seção de detalhe para todo e cada registro processado;
5. Column Footer: esta seção aparece ao final de cada coluna;
6. Page Footer: esta seção aparece ao final de cada página;
7. Last Page Footer: esta seção aparece ao final da última página;
8. Summary: esta seção aparece ao término do relatório, logo após o último registro.
Quem já usou o Crystal Reports ou outro gerador gráfico vai começar a entender
só de olhar... Para começar, especificamos uma consulta SQL apropriada para o relatório,
utilizando o menu “Data - Report Query”. Inclua o texto “select idpais,pais from cm_pais”,
conforme figura abaixo:
Agora clique em “OK”, para voltar à janela principal. Lá, dê um duplo clique na
entrada “Fields” da janela “Library” no canto inferior direito da janela. Devem aparecer os
campos IDPAIS e PAIS, como abaixo:
3
Arraste-os para a seção “detail” do layout e acione o menu “Build-Execute (with
active connection)” (ou use a última setinha do primeiro toolbar).
Salve o relatório em alguma pasta apropriada, aguarde alguns segundos e...
pronto! Aí está o Jasper em ação!
4
Note os componentes do toolbar. Querendo adicionar um texto de título, por
exemplo, use o botão
. Ajuste as dimensões das seções do relatório conforme
desejado, inclua títulos, data, número de página, etc. Enfim, explore o ambiente, pois ele
tem muito a oferecer. Ao final poderíamos ter um layout como abaixo:
O que geraria um relatório como o seguinte:
Esta é a parte inicial de nossa
experiência com o iReport (instalação, criação
de conexão e primeiros passos). Maiores
detalhes, “perfumarias” e congêneres serão
discutidos e aprendidos em conjunto...
5
Download
Random flashcards
paulo

2 Cartões paulonetgbi

Criar flashcards