1 ALGORITMOS – VT1 UNIVERSIDADE SALGADO DE OLIVEIRA

Propaganda
UNIVERSIDADE SALGADO DE OLIVEIRA
CURSO DE ENGENHARIA CIVIL
CC II - ALGORITMOS
Prof. : Celso Cardoso Neto
VT 04 - TRABALHO INDIVIDUAL – 11/05/2015 – 2 pontos
MARQUE EM AMARELO A RESPOSTA CORRETA
ENVIAR POR E-MAIL PARA [email protected] até 24:00h de
15/06/2015
Aluno:
Matrícula:
Para comprovar o resultado, elabore o algoritmo no VisualG.
Anexe a janela do algoritmo digitado e a correspondente janela de execução.
1.
Elaborar um algoritmo no VisualG que calcule a conta de consumo de energia elétrica de um consumidor.
Para isso,
 leia o código do consumidor (1595768), o preço do kW (R$0,70) e o consumo mensal em kW (550
kW).
 Incluir um adicional de 1% sobre o consumo a título do uso do sistema de bandeira vermelha
 Imprima o código do consumidor e o total a pagar.
 Sabe-se que total a pagar = preço x quantidade e que o total a pagar mínimo é de R$ 11,20 (caso o
valor a pagar seja menor que esse, deve-se atribuir esse valor para pagamento).
Obs: Não usar conceito de procedimento
Código em VisualG:
Execução em VisualG:
2.
Elaborar um algoritmo no VisualG que determine, com 4 casas decimais, o seno, cosseno e tangente, dos
seguintes ângulos:
 30º
 45º
 60º
 90º
 180º
Obs: É apresentado abaixo o código. Está correto? Qual é o erro?
Código em VisualG:
algoritmo "TRIGONOMETRIA"
var
N : inteiro
X, RD : real
inicio
para N de 1 ate 5 faca
se N = 1 entao
x <- 30
escreval
escreval("<<< Angulo de 30 graus >>>")
senao
se N = 2 entao
x <- 45
escreval
escreval("<<< Angulo de 45 graus >>>")
senao
2
ALGORITMOS – VT1
se N = 3 entao
x <- 60
escreval
escreval("<<< Angulo de 60 graus >>>")
senao
se N = 4 entao
x <- 90
escreval
escreval("<<< Angulo de 90 graus >>>")
senao
x <- 180
escreval
escreval("<<< Angulo de 180 graus >>>")
fimse
fimse
fimse
fimse
rd <- (x * PI)/180
escreval("<<< Seno de x = ",sen(rd):6:4)
escreval("<<< Cosseno de x = ",cos(rd):6:4)
escreval("<<< Tangente de x = ",tan(rd):6:4)
fimpara
fimalgoritmo
Execução em VisualG:
3.
Uma pesquisa sobre características físicas da população de uma determinada região coletou os seguintes
dados, referentes a cada habitante, para serem analisados:
 Sexo (masculino, feminino)
 Cor dos olhos (azuis, verdes, castanhos, negros);
 Cor dos cabelos (louros, castanhos, negros);
 Idade em anos.
Obs: (1) O programa deve ler os dados de 6 habitantes, conforme a tabela abaixo.
(2) O programa deverá imprimir a quantidade de homens, de mulheres, de pessoas com olhos azuis,
de pessoas com cabelos castanhos, de pessoas com idade <=35 e de pessoas com idade >35
anos.
(3) Utilizar conceito de procedimento
Obs: Para fins de teste, utilizar os dados conforme a tabela abaixo.
IDENTIFICAÇÃO
IDADE
SEXO
OLHOS
1
30
M
AZUL
2
40
F
VERDE
3
23
F
CASTANHO
4
31
M
NEGRO
5
29
F
AZUL
6
-1
-------
CABELOS
LOURO
CASTANHO
NEGRO
CASTANHO
CASTANHO
----
Código em VisualG:
Execução em VisualG:
4.
Elaborar um algoritmo que
Usando o procedimento LER, leia 7 números diferentes e desordenados.
Usando o procedimento IMPRIMIR_LIDOS, imprimir os números lidos.
Usando o procedimento CLASSIFICAR_NUMEROS_ASCENDENTE, ordenar os sete números pelo
método da bolha (“Bubblesort”).
 Usando o procedimento IMPRIMIR_ORDENADOS, imprimir os números CLASSIFICADOS.



Código em VisualG:
3
ALGORITMOS – VT1
Execução em VisualG:
5.
Elaborar um algoritmo que gere e imprima doze termos da Série de Fibonacci, conforme abaixo.
POSIÇÃO 1
2
3
4
5
6
7
8
9
10
11
12
TERMO
1
1
2
3
5
8
13
21
34
55
89
144
Lei de formação:
FIBO(posição) = 1, para posição < 3
FIBO(posição) = FIBO(posição-1) + FIBO(posição-2), para posição >= 3
Obs: Usar variável indexada e procedimentos.
Código em VisualG:
Execução em VisualG:
6.
Elaborar um algoritmo que
Usando o procedimento LER, leia 7 números diferentes e desordenados.
Usando o procedimento IMPRIMIR_LIDOS, imprimir os números lidos.
Usando o procedimento CLASSIFICAR_NUMEROS_ASCENDENTE, ordenar os sete números pelo
método da bolha (“Bubblesort”).
 Usando o procedimento IMPRIMIR_ORDENADOS, imprimir os números CLASSIFICADOS.



Código em VisualG:
Execução em VisualG:
7.
Elaborar um algoritmo que leia a matriz M. Em seguida,
imprima a matriz
M e sua transposta Mt
.
Obs: O algoritmo deverá ser elaborado utilizando procedimentos.
Código em VisualG:
Execução em VisualG:
8.
Elaborar um algoritmo que gera as 7 primeiras linhas
do arranjo de números conhecido por Triângulo de
Pascal. Conforme indicado na figura, cada linha do
triângulo começa e termina com o número 1 e cada
um dos números internos é a soma de dois números
da linha imediatamente anterior.
Obs: O algoritmo deverá utilizar o conceito de
PROCEDIMENTO.
Código em VisualG:
Execução em VisualG:
ALGORITMOS – VT1
9.
Elaborar um algoritmo que multiplica duas matrizes
X[3,4] e Y[4,2] e que armazena o resultado em Z[3,2].
Obs: (1) O algoritmo deverá ser elaborado utilizando
procedimentos.
(2) O algoritmo deverá ler as matrizes X e Y, multiplicálas e armazenar a matriz produto em Z. Ao final,
imprimir as matrizes X, Y e Z (em formato de matriz,
conforme ilustrado ao lado).
Código em VisualG:
Execução em VisualG:
4
Download
Random flashcards
paulo

2 Cartões paulonetgbi

Anamnese

2 Cartões oauth2_google_3d715a2d-c2e6-4bfb-b64e-c9a45261b2b4

A Jornada do Herói

6 Cartões filipe.donner

paulo

2 Cartões oauth2_google_ddd7feab-6dd5-47da-9583-cdda567b48b3

Matemática

2 Cartões Elma gomes

Criar flashcards